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1. Introduction

The Genie IV program allows you to collect, analyze, and display EEG, EMG, and ECG data from
the Thymatron System IV in real-time. It also has functions to save and playback treatment sessions,
and edit the patient information associated with a set of data. If desired, Genie IV can automatically
collect the data of multiple treatment sessions, eliminating the need for any operator intervention in
between patients. 

2. Installation

Program Files

Genie IV works with MS Windows XP, Vista, 7, and 8. If you don’t already have the Genie IV
software, you can download it from

http://thymatron.com/sub_downloads.asp

The program is self-contained, and does not require you to run an installer. Just create a folder on
your computer called “Genie” and drag the  Genie[xxx].exe1,  DevIL.dll, and  Sample.dat
files from your download into that folder. Any data files you save will be kept in that directory, as
well as a  Genie.cfg file that stores your settings when you quit the program. To run Genie IV,
double-click the Genie[xxx] file. 

Connecting the Serial Cable

The Genie IV software communicates with the Thymatron System IV using a 9-pin serial cable.
Connect one end to the serial port, labeled RS232, on the rear panel of the Thymatron, and the other
end to a 9-pin port on your computer. If your computer does not have a built-in serial port, you can
use a USB-to-Serial converter: we have tested the Genie with Keyspan’s USA-19QW and USA-
19HS adapters,  and adapters based on the PL2303 chipset;  these can also be purchased through
Somatics, if you wish. If you use a USB-to-Serial adapter,  you will  need Genie version 6.61 or
higher.

You will need to know the “COM Number” of your serial port, the first time you run Genie. Though
this number varies from computer to computer, there are some guidelines that might help you: 

• If you have a built-in serial port, try COM1. 
• If  you are using a USB-to-Serial  converter,  and also have a modem on your  computer,  try

1 The [xxx] represents the version number of the particular Genie your are using; for instance, Genie641.exe. 
Also, depending on how your Windows installation is configured, the .exe extension may be hidden.
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COM5. 
• If you are using a USB-to-Serial converter, but do not have a modem, try COM1 or COM2. 
• You can also find the COM ports available on your computer by using the Device Manager

function of Windows2

To set the COM port, open the Connect menu once you have run the program, and choose the Set
Port item to display a list of COM ports from which you can select one. Note that if you select an
invalid COM port, the Genie software will give you a warning, and you can try another. There is no

harm in trying different COM ports until you find the correct one. 

3. User Interface

The first time you run Genie IV, it will attempt to detect your COM port, and then you will see a
gray screen with a menu bar at the top. The menus are: 

File Used to load and save data to disk, print, and exit the program.

Connect For sending to and receiving data from the Thymatron.

PatientInfo Allows you to set patient information, such as the name, age, and sex, stored with the
data.

Tools This  menu is  available  only  when a  window is  open.  It  contains  commands for
recording and playing back data.

Format Shown only when the Report window is active, this menu allows you to configure
the types of information displayed, and the formatting of the graph.

Window Used to open various types of windows (Graph, FFT, etc.) for viewing the collected
data,  and  for  selecting  among the  windows you have open.  These  are  discussed
individually in section 6 on page 5.

About Shows the version number of the Genie IV.

In  the  Tools  menu  there  are  two items,  Play  Control  and  Channel  Settings,  that  open floating
“control panels” that allow you to more easily activate recording and playback functions.  These
controls are discussed in section 9 on page 8.

4. Collecting Data

To monitor in real-time the channels of the Thymatron,

1. Run the Genie program as described above 

2. Open the Window menu and select the Graph item. A four-channel graph screen will appear,
as well as the Control and Setting floating panels. 

3. Acquire an impedance reading by holding the Impedance button on the Thymatron until  a

2 When using Windows 7 or 8, you can open the Start menu and simply type "Device Manager" to open it.
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value is shown on the LED display. Note that the patient does not have to be hooked up to the
stimulus electrodes—you can continue monitoring with a 3000Ω reading. 

4. On  the  Control  panel,  click  the  Monitor  button.  The  Genie  will  begin  to  display  data,
organized into 1.28 second epochs, or segments. 

5. When you wish to stop monitoring, click on the Stop Mon button in the Control panel. 

To upload the collected data from the Thymatron to Genie,

1. Press the FlexDial™ on the Thymatron, and rotate the dial until “DATA OUT” is displayed on
the 8-character LED. 

2. Press the FlexDial, and then rotate it until “RAW DATA” is shown. 

3. In the Genie program, open the Connect menu and click Receive Data. 

4. Press the FlexDial to begin the data upload process. 

5. When the transfer finishes, press the Impedence Test  button on the Thymatron to exit  the
FlexDial menu. 

6. If you wish, you can use the PatientInfo menu to store information such as the name, sex, age,
etc. of the patient before saving the data. 

See section  9 on page  8 for detailed information on how to review the collected data,  alter  the
playback speed and channel gain, and mark any artifacts found; and see section  7 on page  6 for
instructions on saving and loading data to files on your computer. 

Auto Upload

Auto Upload is the feature that provides for operator-free data collection from multiple patients. To
use it, 

1. From the Connect menu, select Auto Upload. 

2. Your files will be named according to the date, time, and a sequence number. You can choose
the directory in which you want to store the files. 

3. When you have chosen the directory, click Upload. 

4. Ensure that auto-upload mode is active on the Thymatron.3

At this point, the Genie IV is ready: it will begin collecting data when treatment is initiated, and will
end when the Start/Stop button on the Thymatron is pressed after treatment. It then saves the data to
a file, and is ready for the next patient.

Automatic Operation

Using  the  monitoring  and  automatic  upload  features  together  provides  a  convenient  method  of
operating the Genie IV when treating several patients in a row. To set up the software, 

3 Refer to the Thymatron System IV instruction manual for full directions on how to do this; this is only a 
brief summary: use the FlexDial → Upload → Load Raw
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1. Turn on Auto Upload as described in section . 

2. Begin monitoring the patient according to the directions in section 4. 

3. The graph screen will show real-time traces of selected channels. 

4. While the stimulus is being delivered, the graph will pause. 

5. After the Start/Stop button on the printer is pressed, Genie will automatically upload data from
the Thymatron, save it, and then wait for the next patient to be treated. 

6. When the impedance has been acquired on the next patient, the Genie will automatically begin
monitoring again. 
   If  you  would  like  to  perform  post-treatment  monitoring  on  a  patient,  obtain  another
impedance reading and the Genie will resume monitoring. 

At the end of the day, you will have a number of files saved by Genie in a folder on your computer.
It is often a good idea to go through these files and rename them to more descriptive names; also,
you can open the saved data files in Genie and use the PatientInfo menu to enter more detailed
characteristics (name, age, etc.). 

5. Report Window

The Report Window (Window menu→Report) allows you to view and print a treatment report with
similar  information to the paper printout  from the Thymatron itself.  When you open the Report
window, you'll see a Format menu that allows you to choose which types of information appear, and,
if you choose to display a graph, the time, scale, and formatting of that graph.

Here you can see the options available in the Format menu: 

 

To save a treatment Report to a file,  print (File→Print) the report window to a PDF writer (ex.
Acrobat or PDFCreator), which will yield a high-quality vector PDF version of the information and
graph.
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6. Analysis Screens

In addition to the Graph window, you can view real-time analyses of the data in the FFT, Bands, and
Spectrum  windows;  and  a  summary  of  the  treatment,  similar  to  the  one  printed  out  by  the
Thymatron, in the Report window. To open any of these displays, use the Window menu. When you
are looking at the FFT, Bands, or Spectrum display, an additional Spectrum menu will be available.
It allows you to choose between an analysis of the accumulated spectrum data thus far (Accumulated
Spectrum), or just the current segment (Current Segment). Depending on the type of window you
have open, the Spectrum or Format menus may have additionally functions, as described below.

Graph The Graph window displays traces from EEG channels 1 & 2, and up to two more
EEG channels, or EMG and ECG channels. See section  on page 8 for instructions on
how to configure the graph display.

FFT The FFT window shows a 32-bar display of the FFT analysis of the EEG channels.

Bands The Bands window displays the numeric values of the absolute EEG power, relative
EEG power, % interhemispheric coherence, and % interhemispheric asymmetry, for
each of the four standard frequency bands (delta, theta, alpha, beta) plus 2 additional
user-assignable  bandwidths.  These variables are  used to  assess  the  relative inter-
hemispheric symmetry in EEG amplitude and phase. 

When you are collecting in four-channel mode, you can use the Spectrum menu
to select any pair of EEG channels to analyze. Also the Spectrum menu will contain
a Set Bands item that lets you choose the range (in Hz) for each of the frequency
bands.

Any number of separate Bands windows may be opened simultaneously by using
the Window menu and selecting the Bands item.

Spectrum The  Spectrum  displays  numeric  values  for  absolute  power,  relative  power,
asymmetry, and coherence, for each of 32 frequency points, in steps of 0.78 Hz. 

When you are collecting in four-channel EEG mode, you can use the Spectrum
menu to select any pair of EEG channels to analyze. 

Any number of separate Spectrum windows may be opened simultaneously by
using the Window menu and selecting the Spectrum item. 
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7. Loading and Saving Data to Disk

The File menu has items that relate to loading and saving data to your computer.

 Menu Item Function

New Clears any data you have collected so far, and readies the Genie IV to accept
new data.

Open Allows you to choose a file from which to load saved data.

Save Writes your current data to disk. 

Save As Allows you to choose a file name under which to save. 

Batch Convert Convert multiple data files to text (see the next section)

Save As Text Exports data as text (see below). 

Print Lets you choose among the various windows, and sends your selection to a
printer.

Exit Closes the software.

Batch Conversion

Genie version 6.81 and newer can convert multiple .DAT files to text in one batch operation. Select
the File→Batch Convert... menu item, and you'll be presented with a file dialog in which you can
select multiple .DAT files at once: hold down Ctrl  or Shift,  and select all  the files you wish to
convert. You will then be shown another file dialog, to choose the directory in which to save the
resulting text files. Each .DAT file will result in two text files: one will have a "-info.txt" suffix, and
the other a "-raw.txt" suffix. These contain the patient and treatment information reports, and the raw
monitoring data, respectively.

Exporting as Text

Normally, Genie IV saves data in a binary format in files with a .DAT or .EDT extension, which are
readable only by the Genie software. It may be useful to export the raw data, analysis windows, or
summary report as a text file, so that it can be read by other software, for instance MS Excel. 

To export a specific window as a text file4, 

1. Open the appropriate display (Graph, FFT, etc.) using the Window menu. 

2. Choose Save As Text... from the File menu. 

3. You will be asked if you would like to include the patient information with the text output, and
also for a file name. 

4 Specifically, these will be in Comma-Separated Value (CSV) format, which is a standard for text files that is
interoperable among many programs.
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If you want to import this text file into Excel 

1. Choose Open from Excel’s file menu, select the appropriate file name, and then use Excel’s
data import wizard to continue the process. 

2. On the first page, choose the “Delimited” data type. 

3. On the next page, ensure that only “Comma” is selected as the delimiter—by default Tab will
be selected, so uncheck it 

4. On the third page you may accept the default of “General” column types. 

Exporting as Images

Genie version 6.61 and above can export the graph as a series of PNG image files, which you can
assemble into a PDF (using third-party software such as Adobe Acrobat or the free PDFCreator),
embed in other documents, print, and so forth. To use this feature,

1. Ensure the Graph window is showing (Window menu→Graph).

2. Select the File menu→Save as Image.  This will open a dialog prompting for the base filename
and directory where you want to store the PNG files. Each screenful of graph data will be
saved in files consecutively named basename-1.png,  basename-2.png, [...]. You can choose to
export all pages of the graph, a subset, or just the current view on the screen.

Import/Export Patient Info

Genie version 6.8 and above provides a method to set the patient information of one or multiple files
to be the same as another file. There are two scenarios in which this is convenient:

Import - When you have a file open, and want to fill in the Patient Info with the fields from another
treatment file, click Import and choose the filename you wish to import from.

Export - You can save the current treatment's patient information to multiple files at once. This is
useful if, for example, you have many treatments saved from the same patient, but the Patient Info is
blank for those files. Open one treatment file, fill in the Patient Info appropriately, and then click
Export.  By holding the Ctrl  key,  you can select multiple target files; once you click Export,  the
current Patient Info will be saved into all of those files.

8. Sending and Receiving Data from the Thymatron

In the Connect menu are a number of functions related to transferring data between the computer and
the Thymatron.

 Menu Item Function

Send Data Transmits data from Genie to the Thymatron (see below). 

Receive Data Uploads data from the Thymatron to Genie, as described above. 
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Send Name Sets the name printed on the Thymatron summary report.

Auto Upload Toggles auto-upload mode, as described above.

Set Port Specifies to which COM port the Thymatron is connected.

To use the Send Data and Send Name functions, you must prepare the Thymatron to receive data: 

1. Press the FlexDial on the Thymatron, and rotate the dial until “DATA IN” is displayed on the
8-character LED. 

2. Press the FlexDial; DATA IN will flash on the display. 

3. Press the FlexDial again to make the Thymatron ready to receive data. 

4. In the Genie program, open the Connect menu and click Send Data or Send Name. 

5. When the transfer finishes, press the Impedence Test  button on the Thymatron to exit  the
FlexDial menu. 

To use the Receive Data function, follow the steps given previously in the discussion of Collecting
Data. 

9. Monitoring and Playback Controls

Control Panel

Once you have uploaded data from the Thymatron or loaded a file from disk, you can playback that
data at a variety of speeds and mark any segments that contain artifacts. 

On the Control panel, available from the Tools menu, you can select a subset of the data to review
and change the speed at which it is played back. To view only a specific time range, type in the
desired value into the Time Set field. From the Speed drop-down box, you can choose the playback
speed from 25%—500% of real time.

There are also certain controls available while you are playing back data:

PlayBack/StopBack Starts and stops playback, respectively. 

Monitor/StopMon Begins and ends monitoring of the Thymatron, respectively. 

Reset Jumps to the beginning of the collected data.

Reject Marks the segment  currently being viewed as an artifact,  so  that  it  won’t
factor in to the statistical analyses performed on the data set. 

Settings Panel

From the Settings panel,  available through the Tools menu, you can customize the behavior and
display of the input channels. To enable a channel, ensure that there is a checkmark next to its On
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label. For channels 3 & 4, you can select among EEG, EMG, and ECG inputs. The Scale dropdown
box lets you change the display scale of each channel, in μV . The Artifact field contains a value in
μV above which a segment will be automatically flagged as an artifact.
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Keyboard Shortcuts

Most  common operations  have equivalent  keyboard  shortcuts,  which can make  using the Genie
software much more efficient; a table of these shortcuts is given.

Function Shortcut

New Ctrl+N

Open Ctrl+O

Save Ctrl+S

Print Ctrl+P

Send Data Ctrl+F2

Receive Data Ctrl+F3

Auto Upload Ctrl+U

PlayBack/Stop Playback Ctrl+B

Monitor/Stop Monitoring Ctrl+T

Reset Ctrl+R

Reject Ctrl+J
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